Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up
  1. Need help? Something arrived broken? Submit a support request here.
  2. Hey All. Thanks for your patience while I updated and overhauled the forums! - Harry

Y axis slip

Discussion in 'Troubleshooting' started by mark tomlinson, Oct 27, 2013.

  1. mark tomlinson

    mark tomlinson Well-Known Member

    So, after my adventure sorting out the issues with the pulley loose on the X axis drive, last night slip on the Y axis drove me to COMPLETELY tear this thing down to get to the Y axis drive motor.
    The EXACT same issue existed for that. The Pulley was loose on the drive shaft. (in full-disclosure mode mode it was Robo3D support who suggested that as the problem for the X axis issue and they were dead on)

    I loctighted the allen for this and looked far and wide for any other screws to apply said loctite to.

    This is not really a question but a caution that you may also need to tighten and loctite all of the drive pulley fittings.

    I am a bit disappointed with that, this should be part of the construction (Robo3D folks-- please add this).

    One hour to do it all (tear-down, fix and reassemble) and that DOES say very positive things about the construction and how open this printer is for self-fixit type work, but PLEASE add the loctite during assembly :)

    I am giving it a couple of hours for the loctite to dry and meanwhile am off to WallyWorld (Walmart) for an approved spatula ;)
  2. Das Wookie

    Das Wookie Member

    Glad you got that all sorted out! It seems that the assembly folks are being somewhat unpredicatable as to which bolts are tightened, and by how much. One of my bolt heads was stripped in assembly of the print head and rather than back it out, and use another... they just left it there, too loose. That's what caused my hotend to self destruct. Also, my Z stop switch was overtightened and cracked the plastic, causing it to very easily slide down the shaft resulting in MUCH screwing about with the Z height / bed leveling until I finally figured out that was the issue.

    QC issues are a ***** for startups. Hardware moreso. Honestly, these guys are doing great compared to some organizations I've worked with, and for, in regard to producing a quality product. These initial bugs will get sorted out and QC will improve over time.

    I think a big part of it is having reasonable expectations... when I buy machine tools from China, I consider them a Pre-Assembled Kit, rather than a complete machine... and the first thing I generally do after the initial "does it work at all" is then tear it down, inspect, adjust, replace/fix/upgrade whatever is necessary, and then re-assemble. I think that the R3D is better in that regard, but I think we should all have the thought that this is a small group of guys starting a company and we are the initial beta-testers of the production process. We are going to find bugs. We are going to have issues. The BIG plus here is that the Robo guys are being great (at least to me so far) about resolving those issues and making sure we are happy and getting fixes. Maybe not as fast as we'd like, but we also have to remember it's a small company struggling to get through these initial steps. It is, after all, a kickstarter project that succeeded beyond their wildest expectations, and they are now running faster than they ever thought they would. Put yourself in their shoes, and think from their mindset, and it gets easier to relax a bit and give 'em a bit of a break.

    (Says the guy who's printer self destructed after ~18 hours of use. I COULD be screaming for heads on pikes... instead, I'm saying "Give 'em a break. They will make it right, eventually.") {shrug}
  3. keraynopoylos

    keraynopoylos Member

    I will try it too.

    Currently I cant print anything as the Y layers keep slipping, even on short objects now.

    I guess I'm supposed to find one screw(allen), vertical to the axis of the motor shaft/puller, right?

    I'll give it a go as there's nothing else I can try, given that I've already tightened the belt...
  4. mark tomlinson

    mark tomlinson Well-Known Member

    If you look at the belt on the X axis you can see the pulley on the shaft of the drive motor.
    There is a similar arrangement on the Y axis (except that the belt is straight though and does not loop around). That is all below the bed.

    In both cases you have a motor with a drive sprocket that the belt loops through. The sprocket is attached to the motor shaft with an allen set-screw. Make sure it is tight and (my advice) add some thread-lock.

    Both my X and Y drive have now suffered from that. :)

    I am not bad-mouthing them, au contraire, the overall construction is simple, easy and decent quality. BUT they need to add a bit of testing before shipping ... I dig that this is a small and rapidly scaling start-up. It will get better.
  5. mark tomlinson

    mark tomlinson Well-Known Member

    Post-work test printing looks perfect (again).
    Thanks to tesseract for the advice to lube it all while it was apart.
  6. mark tomlinson

    mark tomlinson Well-Known Member


    In your case it would be the pulley (and belt) UNDER the print plate/platter. X is the one that moves around up top, Y is the one that is under the bed and Z is the threaded rods on the sides.

    So far I have touched all three, but it is not horrendous to do and it is working again.
  7. keraynopoylos

    keraynopoylos Member

    Thanks. I have already tightened the belt with no joy...

    Will get an Allen set tomorrow and see if the pulley needs tightening too.
  8. Mike Kelly

    Mike Kelly RoBo3D Forum Administrator Staff Member

    I would definitely check the pulley. Here's how I did it:

    Remove the build platform from the slides

    Remove Stepper motor by the 4 screws

    Use a caliper probe to measure how far the pulley is offset from the drive shaft end, mine was 4mm

    Loosen the set screws using a 1.5mm allen wrench.

    Ensure 2 set screws align with 2 flat faces on the drive shaft. Mine was completely off line with these

    Adjust pulley offset from drive shaft back to correct position and remount motor. Ensure wires are in the same orientation.
  9. Das Wookie

    Das Wookie Member

    You forgot the addition of blue loctite (or CA glue) to the set screws. :)
  10. keraynopoylos

    keraynopoylos Member

    Thanks Mike, but have already done it.

    Didn't remove the pulley. Felt quite rigid. Tried to tighten the(only one) screw of the shaft.

    Will see when I put it back together. Although obviously I'll be remounting on problematic rails, as you can see from my video on the other post...

    All in all, I wouldn't expect this to correct the layers slipping on the Y, as it doesn't appear that it was an issue with the pulley, but then again we'll see.




    Didn't want to superglue anything, in case it needs to be removed for some reason in the future.
  11. Mike Kelly

    Mike Kelly RoBo3D Forum Administrator Staff Member

    I'm too scared of losing the set screws to take them all the way off.
    Did you verify the pulley set screws are properly aligned on the drive shaft? It was hard for me to tell they were even off until I took the motor completely off. I guess the newer model use 2 set screws and a shaft with 2 flat faces. I know jeff was mentioning to me he had to take his pulley off and flatten his drive shaft face to get good contact.

    My rails also had a problem in that they've get jammed around 240 but that seems to be fixed. Time will tell if my pulley fix stopped the y-axis shifting, but so far so good.
  12. Das Wookie

    Das Wookie Member

    Mark had issues with all three of his axis on the pulleys needing some love. It was the axis slip fix for him. For others, it's just been tightening the belt. It's not REALLY obvious if the belt is loose however as you can get slip and not think the belt is loose... so my thoughts here are, when it doubt, fix the pulleys to the flats of the shafts of the steppers, loctite with blue, and tighten that belt well. That SHOULD resolve the slip issues. The pulley on the shaft might not be on the flat, and may still move even with tightening the screw... as you can see, it don't take much to throw off your print!
  13. keraynopoylos

    keraynopoylos Member


    Yes, I did unscrew the motor. There was not clearance to get to the pulley screw otherwise.
    The shaft has one flat surface, hence the one screw. Seemed aligned to the flat surface. Rotating by hand seemed rather firm too.
  14. keraynopoylos

    keraynopoylos Member


    Have already tightened the Y belt over a week ago. By two "teeth" on each end. So it is QUITE tight.It's not gonna be easy to divide the length of the pulley between the 2 parts of the pulley-bearings(towards the front of the bed and towards the back) and have the same tension, while putting it all back together...
  15. Das Wookie

    Das Wookie Member

    Let us know how your prints go then... sounds like everything SHOULD be working now once you're all reassembled.
  16. Das Wookie

    Das Wookie Member

    Also, CA glue breaks pretty easily. Blue loctite is the better solution, but not everyone has that laying around like some of us. I'm partial to the stick type than the liquid. easier to apply and less worry about it getting into something you DON'T want fastened like a bearing or motor or whatnot... Also, you don't need much CA glue. A tiny drop will fasten the setscrew and when you go to remove it yeah, it takes some extra force, but not THAT much extra. Again, you are just going to use a TINY drop of it. Don't "drown" the screw such that you get a film over the entire setscrew. You are just looking for the smallest of thin film on maybe 1/8th of the part before you go to insert it. Blue loctite is easier to control than CA, but folks in the RC planes community use it all the time... and if THEY trust it with their machines, where you've got an (EXPENSIVE) missile moving at high rates of speed... I'd think it's safe to use on a R3D. Heh!
  17. mark tomlinson

    mark tomlinson Well-Known Member

    CA glue dissolves with a touch of acetone as well--which I KNOW we all keep for post-processing ABS :)
  18. mark tomlinson

    mark tomlinson Well-Known Member

    Sadly it sounds like this was not your issue. That would be an easier fix.

    You may have issues with the rails after all or the stepper itself being defective in some way...
  19. Das Wookie

    Das Wookie Member

    Isn't that what the parts washer is for... :)

    Actually, I keep mineral spirits in mine... makes cleaning fast and easy and doesn't evaporate AS quickly... still need to try printing with ABS and see how that does for post processing.
  20. mark tomlinson

    mark tomlinson Well-Known Member

    Mineral Spirits works for PLA?!

    That is good to know :)

Share This Page